Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

[Resolved] Bug - unresponsive state after respring

edited December 2012 in Support
OK... I'm sure its not a super common scenario but i'm sure there are other ways that this comes up but what happened is this:
1) installed the app and started using it...
2) had a message "being sent" (like in an outgoing but hasn't fully finished sending state)
3) resprung the device to finish the installation of caffeine 2 (to keep this alive)
4) when the device came back alive... that message was still there in the sending state but would never send or fail just sat there...

obviously not a common scenario but I'm sure the situation can be brought on by other actions as well...

deleting the bad message off and retyping it alone wasn't enough to fix it... had to delete bad message and then toggling the app off and retyping the message did fix it though... again not a common scenario just reporting it :)

Comments

  • oh and yes that means I went ahead and bought the app... like it a lot so far... very clean!
  • Hi MiniGOD,

    Thanks for taking the plunge and reporting this bug!

    Just a few questions regarding what happened:
    1) Was the contact on iMessage/SMS? Where you sending a file or just text?
    2) When you had the message in the permanent sending state, did you try switching to another conversation and back again or refreshing the page? (if you didn't try this and see it again could you try these 2 suggestions? It would greatly narrow the scope of the bugs location).

  • it was a SMS... just regular text... and yeah tried refreshing the page and switching to another conversation... didn't help... but I just had kind of the same problem where my phone dropped off wifi for some reason... and you know at the top of the screen it was saying connection attempt #5... and a message was in sending b/c of that... but I refreshed the page and that message was gone and it worked right away... so im thinking it has something to do with the message being in some state during a respring only and not just a wifi disconnection
  • not sure if its related or separate... but also for some reason that caffeine 2 wasn't keeping wifi on... so ok... I sent a message and I didn't notice if wifi was on when I sent it or if it turned off in the process of sending it... but i looked at the computer and saw the connection retry on the top bar... and then i woke the phone back up so wifi came on and it automatically connected back... but that message was left in grey as unsent (i guess thats what I means)... not sure if it currently is setup that way or not but when it reconnects it would be good if it checked if any messages were still supposed to be outgoing and then attempted to resend them since it was now reconnected type of thing...

    and also didn't want to start another thread for this but the SBSettings toggle name is really long and cuts off the words of adjacent icons in the notification center panel... instead of saying "Remote Me..." maybe change it to "R. Msgs" or "Rem Msgs" something so it gracefully cuts off rather than ...
  • I will look into the respring issue at some point over the weekend. Hopefully work out what it is!

    Out of all the tweaks I have tried to keep my iPhones WiFi active the only one which properly worked for me was insomnia. These tweaks seem very hit and miss. As for sending messages that have timed out during the POST (which happens if your WiFi keeps dropping), we can't really handle this as once the POST has been sent the data attached (file attachments etc) has disappeared. In this case you will have to manually resend the message.

    With respect to the SBSettings toggle name, we'll come up with something snappy to change it too. =] If you find the SBSettings toggle not working please see this thread for a temp fix: http://remotemessages.com/forum/index.php?p=/discussion/11/sbsettings-toogle#Item_4
  • yeah... insomnia seems to be working just fine right now... maybe some javascript to keep the text active after the post or a right click on the text option to resend it once it goes grey? (again may have to use javascript or something to enable that)... i had to refresh the page and then retype it instead... again hopefully wont have the problem now that insomnia is on but who knows what other users may run into in the similar scenario
  • I've found KeepAwake to be more reliable than Insomnia, so you may want to try that instead...
Sign In or Register to comment.