Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

[Resolved] Infinite reboot/respring loop, even after uninstallation.

edited December 2012 in Support
As the title says, ever since I installed RemoteMessages my phone (iPhone 4S on iOS 5.1.1) has been infinitely rebooting or respringing (sometimes it reboots, sometimes resprings). Even uninstalling RemoteMessages doesn't solve the problem, and the only possible way to use my phone is using the volume-up-boot trick to disable Substrate completely.

I turned crash reporting on in the RM settings before all this started happening so hopefully you'll get a crash dump from it. Let me know if there's anything more I can provide.

Comments

  • First lets look at getting your phone stable again.

    1) Do you have SBSettings and/or biteSMS installed?
    2) Which jailbreak exploit are you using?
    3) Delete the contents of /var/mobile/Library/RemoteMessages (you can remove the whole dir)

    Get back to me about 1&2 and do 3. The only thing we touch that isn't self contained is SBSettings but this would all be auto-removed upon uninstallation.

    RM doesn't have any code in its hooks that could cause an infinite respring/reboot loop.

    Could you also email our support address support (support@beastsoft.co.uk) from within cydia so as to attach a dpkgl.log. This could help us trace any incompatibilities.
  • edited December 2012
    1. Yeah, I use both SBSettings and biteSMS.
    2. Absinthe, I believe.
    3. After deleting the directory, my phone seems like it's back in stable condition. I'm just letting it sit, and haven't seen any unexpected reboots/resprings so far.

    I'll get that log file emailed to you shortly.
    edit: email sent.
  • When you feel brave enough, install Remote Messages again from cydia but DON'T launch it (i.e dont swipe enabled in the settings app). Reboot the device so that the hooks take effect and report back on stability.

    We'll try and narrow down where the fault occurs.
  • Reinstalled again, seems stable so far. Haven't tried enabling it yet.
  • Give it another reboot just to make sure, and send a test SMS or iMessage to yourself or someone else to make sure the hooks arent causing any issues.

    If all is good after that, take the plunge and enable RM in the settings app. Appreciate you sticking through it with us! If the same behaviour happens again (reboots and resprings) we'll dig in a little further.
  • Sending both iMessages and SMS messages worked just fine. Enabled RM in settings, almost immediate crash, now back into the reboot/respring loop.

    It's all good, I write software for a living as well so I'm /very/ familiar with this process, haha.
  • :D

    To stop the crashing delete the file /var/mobile/Library/RemoteMessages/imdeamon-canlaunch and then respring/reboot.

    Could you then run the following commands and email me the output? Once we have verified the file structure we'll go through some quick procedures over email to firmly locate this issue.

    ls -Rl /var/mobile/Library/RemoteMessages
    ls -Rl /Library/Application Support/RemoteMessages
  • Email sent.
  • As a summary of what happened here, the_zeph had a very large SMS database (~2GB) which caused Remote Messages to crash during start up. RM's start up procedures are being revised to take into account extreme DB sizes to mitigate this problem.
Sign In or Register to comment.