Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

CC toggle always says "Off"

edited April 2014 in Bug Reports
Regardless of whether you are turning RM off or on via the CC toggle, the message displayed is "Remote Messages: Off"

Not sure if the problem is with RM implementation or something is up with CC.

Thanks.

Comments

  • Do you see it happen with any other toggles?
  • Just tested. All the others I tried work as expected.
  • I can't reproduce the issue on my device. Can you post some reproduction steps with version numbers of relevant packages + sources?
  • Just to be clear, it is only the text message that comes up when the toggle is pressed that displays the same all the time ("Remote Messages: Off"). The toggle does light up for on and off when toggled off as expected. This is only relevant when I toggle RM off and on from the Control Center.

    I am on an iphone 5S 32gb 7.0.4. All Cydia apps are up to date. I am using CCLoader 1.2.4, CCSystemStatus 1.1.1-1, Flipcontrolcenter 1.0, BiteSMS 8.2.9a, and lots of others. Let me know what else you need.
  • So, for a brief moment before I was connected to wifi and was toggling the cc switch, it said "on" and "off" but the problem this time was that it was opposite of what is indicated by the toggle.
  • Our FlipSwitch toggle is so ridiculously simple it must be some issue with FlipSwitch/CCLoader. I have seen this appear with other toggles recently (Bluetooth mainly), but we'll keep an eye on it from our side.
  • I hate to circle back on this, but the behavior is *only* with RM toggle on my end. I tried reinstalling RM and it didn't change. Are you able to recreate the problem at all? There are only a few times where I've seen it say "Remote Messages: On" and that is ironically when I turn it off, and it happens very rarely.
  • I'll review the toggles code our end, it was written a very long time ago so maybe the frame work has changed in that time. "Remote Messages: XX" Isn't handled by the toggle at all IIRC, that is all directly done by CCLoader/FlipSwitch.
  • Yeah, I just uninstalled flipswitch, CCLoader, RM, etc., ran CCleaner, then reinstalled everything (starting with RM with flipswitch as a dependency) and the behavior is still the same.
  • By any chance, do you have another iDevice you could test this on?

    @Alex do you think maybe there is something lingering on the device that CCleaner isn't getting rid of? I mean, the toggle certainly works for me, so there's clearly a messed up file/config *somewhere*.
  • Al, I just tested on my wife's iPhone 5 (I have 5S). She has very few jailbreak tweaks besides biteSMS, CCLoader and RM. The behavior was identical to my phone.
Sign In or Register to comment.