Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Issues connecting using USB

edited January 2015 in Community
Hello,

I'm trying to use an old iphone 4s that does not have cellular service but is connected to my work wifi for imessaging. My work PC is on a LAN that is on a different subnet then the work wifi. So therefore Im attempting to use the USB method. The issue is I cannot connect even after downloading the itunnel_mux_rev71 software and following the instructions as described. I have verified that the remote messenger is enabled and port set to 333 (I have tried numerous other ports also). When I type in 127.0.0.1:333 both Internet explorer and chrome fail to connect at all. is there an issue with the phone not having cellular service and using wifi to get access to imessaging instead?

Comments

  • Also, this is what my command prompt runs when I run the itunnel_mux - Shortcut. Is this correct?



    C:\Users\joshs\Desktop>cmd /k C:\Users\joshs\Desktop\itunnel_mux_rev71\itunnel_m
    ux.exe --Iport 333 --iport 333

    iphone_tunnel v2.0 for Win/Mac
    Created by novi. (novi.mad@gmail.com)
    Restore mode hack by msft.guy ((rev 5))

    Usage: iphone_tunnel --tunnel [--iport ] [--lport ] [De
    vice ID, 40 digit]]
    OR: iphone_tunnel --autoboot to kick out of the recovery mode
    OR: iphone_tunnel [--ibss ] [--exploit ]
    [--ibec ] [--ramdisk ]
    [--devicetree ] [--kernelcache ]
    Example: iphone_tunnel 22 9876 0123456...abcdef
    Default ports are 22 22

    C:\Users\joshs\Desktop>
  • Hi Joshua.

    The output you pasted from iTunnel is incorrect. Please follow the guide again: http://remotemessages.com/getting-started/#itunnel

    The output of iTunnel should look like this:
    http://modmyi.com/attachments/forums/general/564271d1328406755-emergency-ssh-access-using-pwnd-dfu-mode-ramdisk-photo-4-.jpg

  • In C:\Users\joshs\Desktop>cmd /k C:\Users\joshs\Desktop\itunnel_mux_rev71\itunnel_mux.exe --Iport 333 --iport 333, change --Iport 333 to --lport333 (L, not I)
  • edited January 2015
    Okay I had a typo in one of the entries it appears. But now I'm running into a new issue. I get the correct output now but as soon as I attempt to connect using 127.0.0.1:333 in my browser (IE 11 and Chrome) the command prompt gives me the following:

    [ERROR] locate_AMRecoveryModeDeviceSendFileToDevice: Could not locate function p
    rolog!
    [INFO] Waiting for new TCP connection on port 333
    [INFO] Waiting for device...
    [INFO] Device connected: 804423156a41f5ced203279f40efc41bfa1fb24d
    [INFO] Info: New connection...
    [INFO] Device connected
    [ERROR] USBMuxConnectByPort = 6b, handle=ffffffff
    [ERROR] Error: Device Service
  • Seems to be something to do with Apple Mobile Device Service. Have you tried reinstalling iTunes (and Bonjour, just to be safe) and then doing it again?
  • edited January 2015
    Okay reinstalling Bonjour and iTunes seemed to have resolved the issue.

    Thanks for all the help gentlemen.
Sign In or Register to comment.