Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

iTunnel Error 0x2

edited January 2015 in Support
All of a sudden iTunnel stopped working for me today. When I would try to start it, the window would pop up and immediately close. I tried starting it in a command prompt and got this message:

[ERROR] Error 0x2 (2): 'No such file or directory'
[FATAL] Could not locate 'Apple Mobile Device Support' folder path in registry: ABORTING

Any idea what's going on? I did just install the latest version of iTunes. Could they have changed the location of the driver or something?

Comments

  • edited February 2015
    Interesting. Thanks for the reply.
    EDIT: Not sure if anyone cares, but I think I may have figured out what the problem is. It looks like the latest version of iTunes moves all the registry values to a new folder called Apple Mobile Device Service, whereas before they were all in a folder called Apple Mobile Device. Would it be possible to simply copy all the registry values from the new folder to the old one? In the mean time, I've reverted back to iTunes 11.4. Just thought I would share my findings.
  • Thanks tasty.... i'm gonna try that before i downgrade
  • no luck... the code on libMobiledevice looks for:

    HKEY_LOCAL_MACHINE, L"SOFTWARE\\Apple Inc.\\Apple Mobile Device Support", L"InstallDir"

    https://code.google.com/p/iphonetunnel-usbmuxconnectbyport

  • Has anyone found a fix for this yet?
  • I tried for a like an hour ... but was not successful ... so i reverted too.
  • edited March 2015
    Hi guys,

    I found a work around. Download and install the latest version of iFunBox. Click on Quick Toolbox, then under Advanced, click on USB Tunnel.

    Make sure Remote Messages is turned on, and then under "new USB tunnel..." type in the port number you have set up on your phone. Press detect and create, and it should add your port to the "Created USB Tunnels". You can then point your browser to 127.0.0.1:[your port number].

    Hope it works for you!

    Update - I should note that you have to add the port each time you plug your phone in, but the process isn't difficult.
  • I was able to get the itunnel-mux binary working again by using an older version of the Mobile Support DLLs from iTunes 11.4: https://code.google.com/p/iphonetunnel-usbmuxconnectbyport/issues/detail?id=13#c9
  • Install iTunes 12.0.1.26

    Copy the C:\Program Files (x86)\Common Files\Apple\Apple Mobile Device Support\ folder to C:\Program Files (x86)\Apple Mobile Device Support\

    Edit Registry. Add a string value "InstallDir" with the value data as "C:\Program Files (x86)\Apple Mobile Device Support" in HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Apple Inc.\Apple Mobile Device Support

    Reboot

    Done.
Sign In or Register to comment.