Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Error executing itnl command (mac)

edited February 2013 in Support
Hi

I just bought RM today and used it on my PC and it works great!

When I later tried to install it on my mac and followed the instructions on how to setup usb syncing, I then got this error from the terminal: "[ERROR] bind error -1 !"

Can you guys please help me?

Kind regards
Anders

Comments

  • Hi,
    We don't actually have anything to do with itunnel but we can try and help where we can (Google might be better or post on itunnels google site!

    (http://code.google.com/p/iphonetunnel-usbmuxconnectbyport/)

    The website states that for the mac version you need: "Intel Mac with newish iTunes (9.1 is probably not required, but recommended)."

    Can you paste the actual command you are using to launch itunnel_usbmux?
  • This is the exact command I use "./itnl --lport 333 --iport 333" (of course without the quotes)

    I am in the specified folder while doing so and every time I receive "[ERROR] bind error -1 !"

    I would be very thankful if it would be possible to solve this problem. I am on a 2012 macbook pro with mountain lion and the latest version of iTunes (11.0.1)
  • Try running "sudo ./itnl --lport 333 --iport 333"
  • edited February 2013
    @Al Thank you Al! that solved my problem :)

    Do I need to run this command every time I want to connect the iphone via usb?
  • Pretty much, there may be a nicer solution available by now for USB tunnelling. I believe iFunBox supports it. Let me know if you find anything better and I'll put it in the guide :)
  • I'm still getting the bind error "[ERROR] bind error -1 !" even when using the above sudo command.
  • I have a 2011 Macbook air with mavericks installed.
  • @josher Can you please paste the whole command?
  • Wow Al, you're so helpful! Even when people aren't using your product through it's intended purpose, you help them. Great job, thanks for the fantastic product!
  • @JonLuca The majority of problems tend to be connectivity, not really something we officially support. :P
Sign In or Register to comment.