Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Some messages wont send/take a long time to send (iOS 8.1)

edited January 2015 in Bug Reports
Hi guys. I'm having trouble sending out messages to people. Whenever I send a message, it will be faded for a while until it actually gets sent out. Sometimes this causes my messages not to be sent in the proper order. The delay could take anywhere from 10 seconds to 2 minutes until the message gets sent out. I don't think I had this problem back on iOS 7.

Thanks for all the amazing work guys. Despite the minor bug, this app is still well worth it!


  • edited December 2014
    I've noticed that when I turn on the authentication feature, it will pop up the authentication box every once in a while. Does this mean I'm disconnecting?

    EDIT: Tried RM on Internet Explorer rather than Google Chrome and it seems to be working just fine. Is there something I can do so that it works on Chrome?
  • edited December 2014
    Same problem here with Firefox, some messages won't sent, not yet after 2 minutes, even Insomnia does not make it better... sometimes i have to reconnect RM, this is annoying...
    I sent the author en email in Cydia, but he does not send me an answer yet...
    On iOS 7 it worked excellent, i hope there will be an update available!

    EDIT: i have version 3.1.1 and the issue wasnt fixed! :-(
  • I've noticed that my device keeps connecting several times. I'm assuming that it is not normal that there are this many connections?
  • I can't access Remote Messages at all any more. This is the message I get when I open itunnel_mux.
  • You upgraded/uninstalled iTunes or something? Btw you know itunnel_mux is nothing to do with us right? Please take issues specifically to do with iTunnel to their forums :)
  • edited January 2015
    I was running on an older version of iTunes. I am not only getting this issue via USB connection with iTunnel but also through WiFi connection.

    I just upgraded iTunes to the latest version but the issue still seems to be recurring (iTunnel and WiFi). I don't believe that this is a iTunnel specific issue.

    I've also upgraded my phone to iOS 8.1.2 yesterday and re jailbroke my phone thinking that it would fix the issue but it has not.

    Some of my messages are still faded. I have to refresh the page and resend the messages for them to go through. If I don't refresh the page, the page will soon prompt me to re-authenticate myself.
  • Yes, what's the problem? Why does none of the developers give us an answer? I sent 2 or 3 emails with the issue.... none of them were responsed...

    It's really really annoying!
  • @dgao93 iTunnel shouldn't be showing that many reconnections, unless you are reseating your USB cable repeatedly. If it's dropping connection randomly, it's possible that the messages will fail to send and remain in their "pending" (transparent) state.
    "I have to refresh the page and resend the messages for them to go through. "
    If the messages stay after a refresh, it means that remote messages has sent them through to your device successfully, it's done it's job. Can you please load up the same conversation on your phone and see if the messages also display here as "failed to send"? This sounds to me like your device is losing connection randomly, hence the prompts to re-authenticate.

    @Gigatronic The problem is that we can't replicate the problems you are having on our own equipment. If it's a bug with the actual software, we'll jump on that more quickly than we would help someone debug connectivity issues.
    I assume you are also connecting with iTunnel? Can you please replicate the issue whilst monitoring the conversation on your phone, that way you'll be able to see more clearly exactly what's happening. If the message appears on the device, Remote messages has functioned correctly. If you're losing connection on the browser, it would be useful to know exactly /when/ that's happening. If it's random, then I don't really know what to suggest.

    Perhaps connect to OpenSSH and leave a terminal window open, see if that disconnects at the same time as Remote messages?
  • @al Messages do not stay after a refresh. Sometimes when I send 2 consecutive messages, the second one will go through and the first one will stay pending. After I refresh the page, the initially pending message is gone and I have to resend it. The pending messages are not displayed as "failed to send". I've also confirmed that this is not an issue specific to my computer as I have tried this on my school computers as well (via WiFi) and get the same issues.

    I've unplugged and replugged the USB from my phone and it will show that the device has been disconnected (compare with my first screenshot). It seems that actually pulling the cable in and out is not the same as the multiple connections shown in my first screenshot.

    And if this means anything at all, as previously mentioned, this issue occurs more often on Chrome than Internet Explorer. I've tried Safari, Opera and Firefox as well but the issues persist.
  • edited January 2015
    Yes, it's exactly as dgao93 describes.... i also tried different browsers, tried to disable autolock, took no effect....
    And no, i do not connect to iTunnel, i will trie...

    With incoming messages there is no problem, they all come in...
  • Yes that's an important point that I forgot to mention. Even when my messages are pending, it seems that incoming messages are unaffected.
  • edited February 2015

    I pray every day, not for my food, job or family...i do pray every day so my 5S keeps working as great as is working right now. I haven't had not even one crash in months (i haven't even upgrade the tweats i have so everything stays the same...LOL) and i know what you mean when you mentioned IOS 7 since that is what i have (7.1.2).

    Pray for my phone guys!...I LOVE REMOTE MESSAGES.

    Thank you @Al (and crew) for the hard work.
  • Any updates on this?
  • What can I do to help you guys resolve this?
  • Quick question, do any of you guys have SSL turned on inside RM?
  • No I do not.
  • I've been looking into this issue for the last week and have pinned it down to the HTTP server we're using on the backend of RM. Unfortunately the server we're using isn't supported or being maintained any more which puts us into a bit of a dilemma.

    We're looking at swapping it out to a another better supported server but this will take some time for us to complete.
  • edited March 2015
    Is there a reason why this only affects certain people and not all? And have you been able to replicate the issue? Is it possible that it is browser specific? This issue happens much more frequently on Chrome than on IE.
  • AlAl
    edited March 2015
    Is there any kind of pattern between the messages that are failing? Are they generally large, or is it just totally random.
  • It seems to be random. The strange thing is why my device keeps connecting. It shows on iTunnel that it keeps reconnecting. Not an issue with iTunnel either since it reconnects without USB connection as well. So I'm guessing it's something specific with my phone and not my computer since I've tried it on different computers.
  • Yes, its random. One interesting thing is, when a message keeps pending and i'm angry about this, i unlock my device, open the messages-app and pretend that i type something... then the message goes in most of the cases through!

    (Insomnia Pro is activated, the reason is not that de device is "sleeping")

    Does that help you to find the issue, @Al ?
  • This is still occurring for me over WiFi on iOS 8.3. Sent messages from browser will not push through to device until screen is activated. I don't even have to unlock device. I do not have authentication enabled.
  • edited June 2015
    For me the issue is on 8.1
    On iOS7 ther were never problems...

    iTunnel works perfectly, but it's annoying to work with the usb-cable... wifi is way more easier...
  • On 8.3 there are no such problems. Every Message goes throw and i even do not have to use Insomnia... good work guys!

    But: What is the difference?
  • We haven't changed anything, so it must have been something else you had previously installed causing the problem. Glad it's working for you now! :)
  • I just jailbroke for the first time a couple of days ago since they finally got 8.1.3 covered. Never even cared to learn what all the jailbreak stuff was until I realized I hate typing on touch screens and googled for a way to use my PC to type text messages, which led me to Remote Messages. It's the entire reason I jailbroke my phone ha. So I bought RM and I absolutely love using it so far, but I'm having the exact issue described in this thread.

    I use Firefox, no authentication, and I frequently alternate between my home's wifi network and my campus's wifi network. Same issue on either network -- outgoing messages won't send for 30 seconds or sometimes minutes (and perhaps never at all) unless I light up the screen on my iPhone 5 (no unlocking necessary). Should I go to 8.3 (if that's possible at this time; clearly I'm very new to this lol) or is there anything I'd be risking by trying that? Just didn't want to accidentally burn any bridges behind me by haphazardly changing things on my phone! Thanks guys

    PS - Is it normal to not be able to relocate the typing cursor elsewhere within a text message that is being composed on RM? Like if I wanted to fix a typo at the beginning of a sentence I had already typed up -- I'll click but it doesn't move the cursor. Right clicking seems to work, just gotta left click directly after to get rid of the little menu that appears.
  • @cbh148 Glad to hear you're liking it :)
    This sounds like an age old problem whereby your device is turning off wifi to save power in 'sleep mode'. This breaks any RM connections, as of course your iPhone was never designed to be a web server! Unfortunately, there is no neat solution for this. Personally I always have my iPhone plugged in and charging whilst I'm on my computer (at home, or at work) and this makes the wifi connection persist. An alternative that I know quite a few people have used in the past is to install a tweak to force wifi to stay alive, Insomnia was it's name if it's still around. This will impact your battery life so it's not something I'd personally recommend. We've had many requests to include a 'Keep Wifi on' toggle within Remote Messages itself, which is something we're considering for the next version.

    With regards to your text input issue, when I built the UI years ago I made sure everything was working properly in Firefox, but things may have changed since. I'll update FF at my end and see if I can replicate this!
  • @Al Thank you so much for the insight! I've been plugging my phone into my charger for the last 2 days and it's been smooth sailing with super quick message dispatch! Truthfully I've been meaning to pick up a couple of extra charging cables for the convenience of not having to snag the one in my bedroom every day (and remember to bring it back ha) so if it comes down to it that I have to basically plug it into the charger when using RM, then that's not bad at all. Oh and I just tried using RM on Chrome and that has fixed the text input issue, so I suppose it's a Firefox thing. Thank you again for this app and for the help, I really appreciate it!
  • I've been using RM for several months, I was on iOS 7 until 8.4 JB went live and I switched shortly after. Now I have this problem where I never did before on iOS7. I always had good consistent connection to RM and messages would send without delay. However now with 8.4 it disconnects constantly and messages take a long time to send. I understand the wifi connection issue but I've never been one to have my phone plugged in all day and I never had this problem with iOS7 and didn't have insomnia installed. Could anything else be causing this since it didn't happen before under the same use scenario but different iOS? Thanks!
Sign In or Register to comment.